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Outline
1. Introduction to ELAN basics

a. too many topics to list!
2. Advanced topics 

a. ELAN templates
b. controlled vocabulary
c. Different modes
d. export

3. Beyond ELAN
a. linking outside data
b. clipping with fflipper
c. forced alignment



the basics



free download

manual available

forum of users

created by team at Max 
Planck Institute of 
Psycholinguistics

the basics
http://tla.mpi.nl/tools/tla-tools/elan/

can be used on mac, 
pc, linux

continually updated
(version 4.9.2 available as of January 2016)

http://www.lat-mpi.eu/tools
http://www.lat-mpi.eu/tools


Julie Hochgesang’s handy ELAN guide         the basics
https://www.academia.edu/5510439/ELAN_guide

https://www.academia.edu/5510439/ELAN_guide
https://www.academia.edu/5510439/ELAN_guide


ELAN is a time-aligned video transcription tool 
that can be used with different transcription 
systems with different analytical goals (i.e., 
from phonetic to discourse, from linguistic to 
anthropological). 

ELAN defined     the basics



VIDEO 

Can attach/detach

Can resize 

Can attach up to four movies 

Can sync movies

tiers

annotations 

text viewers

annotation density viewer
resize video

zoom (for time)

video controls

scroll

(you can also use the annotation density viewer to 
navigate through your file)

Navigating ELAN      the basics



Right click on the specific area to access the 
drop-down menus

For mac users, CONTROL+click

ELAN the basics 
menus



1. Creating and linking files
2. Creating tiers
3. Creating annotations

Getting started     the basics



open ELAN File>New  OR 
COMMAND+N

select your movie

hit OK movie is now in your eaf
*ELAN only plays movies. It does not edit your 
movie.

save your new file!
*I’d recommend using automatic 
backup -
File > Automatic Backup  

ELAN the basics
step 1: creating and linking files



Files that you create:

.eaf = elan annotation file 
(e.g., like .doc for word, .pdf for preview, .ppt for powerpoint.
this is where the annotations and link to the movie is saved)

Automatically-created ELAN files

.pfsx = preferences
(saves your preferred settings, e.g., video size, video speed, zoom, tier ordering. if you 
delete this file, the annotations are untouched)

.001 = automatic backup file

ELAN the basics
Different types of files

you will always need two files

the movie file and the .eaf 



ELAN plays movies (it does not import, edit or affect the original movie files) 

ELAN remembers the path to the video. So if you move your video, ELAN won’t know and you’ll 
need to tell it where it went (usually a prompt window appears) or if you want to send an eaf to 
someone else, you need to make sure that the movie file goes with it

ELAN the basics
Side note regarding movies



go to Tier>Add new tier

*You may want to delete the default 
tier that’s automatically in each new 
.eaf

*Create the tiers (“categories”) that 
you want

*Tiers are automatically placed here in 
the order you create them

ELAN     the basics
step 2: creating tiers



select the onset and offset 
of what you want to 
annotate (using the blue 
highlight)

doubleclick the blue on the 
appropriate tier and this 
white box opens

type whatever you want in 
the box (glosses, 
observations, notations, 
etc.) and hit return

(if your text is not intact when this closes, 
change this in 
Edit>Preferences>EditPreferences>Editing>S
elect the first two boxes)

ELAN  the basics
step 3: creating annotations

don’t forget to right-click and play around with options on drop-down menu



pink highlighted tier
tier is active (meaning you can create new annotations or delete tiers on this tier) 

red line (the crosshair) indicates where you are in video

blue highlighted tier
annotation is selected 

ELAN
some terms

(if your text is not intact when this closes, change this in 
Edit>Preferences>EditPreferences>Editing>Select the first two 
boxes)

inline edit box

(Click OPTION+M when you’re in inline edit box to get text editor box)
text editor box 



ELAN
understanding the active tier

see how this tier is pink? it’s active. that means 
you can copy annotation fields (and any existing 
annotations in those fields) to this tier. you can 
also create new annotations using shortcut keys 
or delete field from this tier when it’s active. 



ELAN
command+D ‘duplicate’

this is handy for copying annotations of the same length with the same gloss 
(ideal for right and left hand tiers)

annotation has been duplicated1. select annotation to duplicate (needs to be blue) 
2. select tier to copy to (needs to be pink)
3. enter command+D



With the mouse, you can... 
1. Click on the annotation you want to change the timing for
2. Make sure the annotation is within the blue highlight and that the 
annotation field (lines) are blue
3. Hover the cursor over the end that you want to change while 
holding down OPTION and clicking down, you should see an arrow
4. Drag, while arrow’s visible, to desired time and then release the 
key and mouse to save the change

ELAN       the basics
step 3: creating annotations



If you prefer shortcut keys, this is the way to do it. 
1. Click on the annotation that you want to change
2. COMMAND+K to go into selection mode
3. COMMAND+/ to choose which end you want to change
4. Hold down command and arrow to move selection to wherever 
you prefer. 
5. Once you’re at the time you want, COMMAND+RIGHT or LEFT 
ARROW
6. When you’re at the desired time, hit COMMAND+ENTER to save 
changes

ELAN     the basics
step 3: creating annotations



ELAN    the basics
shortcut keys

view>shortcuts



advanced



1. Parent/Child tiers
2. Linguistic types
3. Controlled vocabularies
4. Templates
5. Different modes
6. Exporting annotations

    Advanced



ELAN    advanced
Two different types of tiers

view>shortcuts

Parent tiers (independent tiers)

Child tiers (referring tiers)

Note: it’s possible to build up nested hierarchies 



ELAN    advanced
Two different types of tiers

Tiers from the BSL 
Corpus



ELAN    advanced
Two different types of tiers

view>shortcuts

When creating new child tiers, you will need to 
create a new linguistic type

• A linguistic type denotes the linguistic data that is 
contained in the referring tier. Each type specifies 
a number of constraints or ‘stereotypes’



ELAN    advanced
Four stereotypes

view>shortcuts



ELAN    advanced
Creating a linguistic type

view>shortcuts



ELAN    advanced

RH-Handshape
Linguistic type: Handshape (symbolic 
subdivision)
Controlled vocabulary: handshape

RH-Grammatical category
Linguistic type: Grammatical Category 
(symbolic association)
Controlled vocabulary: Grammatical 
Category

LH-Grammatical category
Linguistic type: Grammatical Category 
(symbolic association)
Controlled vocabulary: Grammatical 
Category



ELAN    advanced

view>shortcuts

edit>edit controlled vocabularies
add list of entries for CV

associate it with a linguistic type
type>add or change type presto! a drop down menu

add CV name and description



ELAN    advanced
Creating a template file

view>shortcuts

.etf means elan template 
file
(creates a template for the tiers and 
their attributes/relationships that 
you’ve established in an .eaf and 
can be used to create new files)



ELAN    advanced
Creating a new annotation file (.eaf) with a template 
file (.etf)

view>shortcuts



ELAN    advanced
Different modes: annotation mode

view>shortcuts



ELAN    advanced
Different modes: media synchronization mode

view>shortcuts



ELAN
transcription mode



ELAN    advanced
Different modes: segmentation mode

view>shortcuts



ELAN advanced
searching



ELAN advanced
searching



ELAN    advanced
Searching for annotations

view>shortcuts



ELAN    advanced
Searching for annotations

view>shortcuts



ELAN advanced 
Merging eafs



ELAN    advanced
Importing/exporting annotations

view>shortcuts



ELAN    advanced
Importing/exporting annotations: Excel

view>shortcuts



Beyond ELAN
 



.tsconf means time series configuration
(specifies the setup and relationship of the time series viewer windows, when they are 
connected.)

ELAN side note



time series viewer beyond ELAN

ELAN can be linked to nearly any type of time-series data.

• time series must be in CSV format
• time column (in seconds)
• other data in other columns

• select and configure what columns are displayed in 
different tracks.



fflipper (using ELAN files outside of ELAN)

beyond ELAN

Because ELAN files are XML, you can access them from 
outside of ELAN.

• If you know how to program, you can use an XML 
parser to extract the data.
• I wrote pyelan, a python module that represents 

ELAN files as a native python data structure.
• I also developed fflipper, a small GUI program that can 

make clips based on annotations.



fflipper (using ELAN files outside of ELAN)

beyond ELAN

Download and installation instructions: github.
com/jonkeane/fflipper 

https://github.com/jonkeane/fflipper
https://github.com/jonkeane/fflipper
https://github.com/jonkeane/fflipper


forced alignment beyond ELAN

ELAN can import PRAAT textgrid files.

• Forced alignment allows you to take an audio file and a 
transcript and produce time annotations for words and 
phonological segments.

• Since many forced aligners output textgrid files, you 
can use forced alignment make elan annotations.



forced alignment beyond ELAN

Can use any forced aligner, one that I have used is: 
github.com/prosodylab/Prosodylab-Aligner

ffmpeg is a command line utility for manipulating videos. 
www.ffmpeg.org which can be installed with homebrew: 
brew install ffmpeg

https://github.com/prosodylab/Prosodylab-Aligner
https://github.com/prosodylab/Prosodylab-Aligner
http://www.ffmpeg.org


Happy ELANing!



Other slides



in ELAN
controlled vocabularies (drop-down menus)
quick segmentation 
different modes (annotation, segmentation, etc.) 
etc. 

along with other software
management of lexicon (LEXUS)
presentation format of ELAN (CUPED)
manage metadata (imdi)
etc. 

ELAN
and much more...



ELAN
tips

• beware: no spell check

• use automatic back-up

• if you move the movie, ELAN won’t know. (Movies are 
NOT imported to ELAN.)

• practice makes almost perfect

• the online manual/forum are excellent resources



hands on with ELAN
exporting: subtitles in QuickTime 7 Pro



hands on with ELAN
exporting: subtitles in QuickTime 7 Pro



hands on with ELAN
a different movie



hands on with ELAN
shifting annotations



ELAN best practices
work flow



ELAN best practices
file saving

120122_JAH_MamaOzj
name of 
video

transcriber 
name

date
YYMMDD

NOTE: It’d be easier if you saved the .eaf in the same file folder as your movie file. If the two files (the .eaf and the 
movie) are separated later, then you will need to re-locate the movie file. You may find the following document 
helpful: “keeping archivists happy” which can be found at http://www.hrelp.org/events/workshops/eldp2008_6/, 
last accessed May 14, 2013.

http://www.hrelp.org/events/workshops/eldp2008_6/


hands on with ELAN
annotation statistics

demonstration in ELAN



hands on with ELAN
complex searches
multiple files

demonstration in ELAN
(also see Johnston’s handout in Dropbox folder)



hands on with ELAN
activity monitor

options>activity monitoring



hands on with ELAN
use grid view

don’t forget to right-click and play around with options on drop-down menu

you can’t add annotations here but you can navigate, edit and delete them
if you do edit annotations here, you have to commit changes by hitting command/control +enter



hands on with ELAN
use text view

don’t forget to right-click and play around with options on drop-down menu

you can’t add annotations here but you can navigate, edit and delete them
if you do edit annotations here, you have to commit changes by hitting command/control +enter



hands on with ELAN
use subtitles viewer

don’t forget to right-click and play around with options on drop-down menu

you can’t add annotations here but you can navigate, edit and delete them
if you do edit annotations here, you have to commit changes by hitting command/control +enter



hands on with ELAN
use segmentation mode



hands on with ELAN
use transcription mode



you can sort tiers

unsorted tiers right-click sorted alphabetically

ELAN
side note



you can hide tiers

all tiers visible right-click all tiers but one hidden

ELAN
side note



hands on with ELAN
tier attributes

tier>change tier attributes

the attributes are also available when you are creating tiers



hands on with ELAN
tier attributes tier>change tier attributes>more options

use this to change tier colors



hands on with ELAN
compare annotators

tier>compare annotators



ELAN    advanced
Controlled vocabularies

view>shortcuts

How to create a controlled vocabulary

1. To make a new one, you need to
* Go to Edit > Edit Controlled Vocabularies
* Add a new one, add the CV name, enter entry values

2 Then you need to create a linguistic type
* Go to Type > Add New Linguistic Type > Set up a stereotype (recommend time 

subdivision) > pick the CV (by 'use controlled vocabulary') 

3. Then you need to create the tier where you will use the controlled vocabulary
* Go to Tier > Add Tier
* Name the tier what you want then pick the parent tier (you need to relate it with something 

- what you set up in step 2) and the linguistic type (the CV is already connected through 
step 2)

4. Then you're all set! 



ELAN    advanced
Different modes: media synchronization mode

view>shortcuts



ELAN    advanced
Importing/exporting annotations

view>shortcuts



ELAN    advanced

Clause tier
Linguistic type: Basic
Controlled vocabulary: None

RH-Argument
Linguistic type: Argument (Included in)
Controlled vocabulary: Argument


